NMBA network by default will not advertise broadcast/multicast networks, so will some tricks to do so. Eigrp by default have split-horrizon capabilities so normally the route will not loops.
for NBMA network i used frame relay, FS1 is multicast and the other pots router using point to point, so i easy for me to figure out the configuration 🙂

in THis labs I use

FS1 as mutipoint / Core

P1R1 and P1R2 as point to  point FR

disables split horison only needs on Core Router since multipoint are in this route and it’s centrals which adv pots router to other pots router.

Here is the the configs :

Router FS1

interface Serial1/1.1 multipoint
 ip address 172.123.123.1 255.255.255.248
!!! split horison need to add for disable split horison so EIGRP will adv to
!!!other pots router
 no ip split-horizon eigrp 1
 frame-relay map ip 172.123.123.2 101 broadcast
 frame-relay map ip 172.123.123.3 102 broadcast

Router P1R1

interface Serial1/0.1 point-to-point
 ip address 172.123.123.2 255.255.255.248
 frame-relay interface-dlci 101

Router P1R2

interface Serial1/0.1 point-to-point
 ip address 172.123.123.3 255.255.255.248
!!! no need broadcast keyword because it's point to point
 frame-relay interface-dlci 102

this Is I already Play with EIGRP:

ip proute from P1R2

D       10.10.1.1 [90/2809856] via 172.123.123.1, 00:06:22, Serial1/0.1
D       10.10.1.2 [90/2809856] via 172.123.123.1, 00:06:22, Serial1/0.1
D       10.10.10.2 [90/2297856] via 172.123.123.1, 00:31:44, Serial1/0.1
D       10.10.10.1 [90/2297856] via 172.123.123.1, 00:31:44, Serial1/0.1

EIGRP neigh

0   172.123.123.1           Se1/0.1          128 00:41:28  253  1518  0  15
Interfaces :
Lo1                0        0/0         0       0/1            0           0
Lo2                0        0/0         0       0/1            0           0
Se1/0.1            1        0/0       253       0/15        1027           0
Se1/1              0        0/0         0       0/15         107           0

!!!s1/1 are not advertise because i prevented on P1R1 with passive interface
!!!see the configs :
 passive-interface Serial1/1
 network 10.10.1.0 0.0.0.3
 network 172.123.123.0 0.0.0.7
 network 172.123.124.0 0.0.0.3
 no auto-summary

!!!now see if I opened the passive interface :
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
 (sec)         (ms)       Cnt Num
1   172.123.124.2           Se1/1             10 00:00:13   46   276  0  26
0   172.123.123.1           Se1/0.1          166 00:45:49  210  1260  0  15

!!!its now 172.123.124.2 are began adv the network:
 10.0.0.0/32 is subnetted, 6 subnets
D       10.10.1.1 [90/2297856] via 172.123.124.2, 00:03:16, Serial1/1
D       10.10.1.2 [90/2297856] via 172.123.124.2, 00:03:16, Serial1/1
D       10.10.10.2 [90/2297856] via 172.123.123.1, 00:03:16, Serial1/0.1
D       10.10.10.1 [90/2297856] via 172.123.123.1, 00:03:16, Serial1/0.1

----------------------------------------------------

IP-EIGRP Topology Table for AS(1)/ID(10.10.2.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
 r - reply Status, s - sia Status 

P 10.10.1.1/32, 1 successors, FD is 2297856
 via 172.123.124.2 (2297856/128256), Serial1/1
P 10.10.2.2/32, 1 successors, FD is 128256
 via Connected, Loopback2
P 10.10.1.2/32, 1 successors, FD is 2297856
 via 172.123.124.2 (2297856/128256), Serial1/1
P 10.10.2.1/32, 1 successors, FD is 128256
 via Connected, Loopback1
P 10.10.10.2/32, 1 successors, FD is 2297856
 via 172.123.123.1 (2297856/128256), Serial1/0.1
P 10.10.10.1/32, 1 successors, FD is 2297856
 via 172.123.123.1 (2297856/128256), Serial1/0.1
P 172.123.124.0/30, 1 successors, FD is 2169856
 via Connected, Serial1/1
P 172.123.123.0/29, 1 successors, FD is 2169856
 via Connected, Serial1/0.1