AMD 2200 ASROCK a320m-hdv and linuxmint

I build my desktop the main reason behind is i need more powerfull and cheap computer for my LAB and my 12 y.o learning purpose because the laptop current use is not quite enought for my labs requirement.

I build computer spect  MB : ASROCK  Proc: AMD and mem: 32 GB PC 2400.

install my linuxmint and blank haha… a day i troubleshooting. googling everything, confusing parts is anyone in the internet say the motherboad that i use is dead end for linux its windows only.  while my labs on linux right now.

what i solve is :

grub :

add this at /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="amdgpu.dc=1 nomodeset"

I delete “quite splash”  since its make me annoyed couple time even at my working fav laptop 😛

and apply the changes

update-grub

reboot and let be in normal boot  and my linuxmint comeback again wirn 32 GB ram and 20 GB SWAP SSD.

Junos Logical System

Virtual System is Logically chassy inside  JUNOS BOX, its posibility for us to create an topology inside Junos Box .

Below is the step:

Set All Interface to vlan Tagging Mode

set interfaces ge-0/0/1 vlan-tagging
set interfaces ge-0/0/2 vlan-tagging
set interfaces ge-0/0/3 vlan-tagging

## Configure Logical System R1

set logical-systems R1 interfaces ge-0/0/1 unit 12 vlan-id 12
set logical-systems R1 interfaces ge-0/0/1 unit 12 family inet address 12.12.12.1/24
set logical-systems R1 interfaces lo0 unit 1 family inet address 1.1.1.1/32

## Configure Logical System R2

set logical-systems R2 interfaces ge-0/0/1 unit 23 vlan-id 23
set logical-systems R2 interfaces ge-0/0/1 unit 23 family inet address 23.23.23.3/24
set logical-systems R2 interfaces ge-0/0/2 unit 20 vlan-id 12
set logical-systems R2 interfaces ge-0/0/2 unit 20 family inet address 12.12.12.2/24
set logical-systems R2 interfaces lo0 unit 2 family inet address 2.2.2.2/32

## Configure Logical System R3

set logical-systems R3 interfaces ge-0/0/3 unit 23 vlan-id 23
set logical-systems R3 interfaces ge-0/0/3 unit 23 family inet address 23.23.23.2/24
set logical-systems R3 interfaces lo0 unit 3 family inet address 3.3.3.3/32

 

Topology :

 

[R1]—-vlan12——-[R2]——–vlan 23—–[R3]

12.12.12.0/24          23.23.23.0/24

 

 

Enable JAVA to our Firefox at UBUNTU

since ubuntu base my favorite for my desktop environtment its difficult for me, if i need to support ASA Firewall which use Java for their ASDM.  the bad thing is Firefox no longer support for JAVA (NPAPI plug-ins.) so I used ESR Firefox to support my need

  1. prerequsite : Download Java and Download ESR Firefox from https://www.mozilla.org/en-US/firefox/organizations/all/ >> choose LInux 64 bit
  2. Install Java
    -copy downloaded JRE to /opt

     cp -v jre-8u151-linux-x64.tar.gz /opt
    
     sudo su

    – change folder to /opt and extract
    cd /opt/

     tar -xzvf jre-8u151-linux-x64.tar.gz

    – Optional for me easy to manage if I simple rename Java folder to JAVA

     mv jre-8u151-linux-x64 JAVA

    – to logout from root

     exit
  3. install JAVA PATH :
    echo JAVA_HOME="/opt/JAVA/bin/java" >> /etc/environtment
  4.  enable java for our firefox
    mkdir -p ~/.mozilla/plugins/
    
    ln -s /opt/JAVA/lib/amd64/libnpjp2.so ~/.mozilla/plugins/
  5.  Extract our Downloaded Firefox
cd Downloadtar -xjvf firefox-52.5.0esr.tar.bz2
cd firefox.\firefox-bin

reload our firefox and associate jnlp file tou firefox to using /opt/JAVA/bin/javaws/
tools >> preferences >> application >> search for JNLP File : use javaws

I also need to try browser that java Support something like : seamonkey, palemoon,etc

but for now I can use my Ubuntu for manage my ASA Firewall.

ASA Lab 01 : L2L IPSEC VPN – IKEv1

Topology/:

Configuration :

ASA0 ASA1
crypto ikev1 enable outside crypto ikev1 enable outside
crypto ikev1 policy 1 crypto ikev1 policy 1
authentication pre-share authentication pre-share
encryption 3des encryption 3des
hash sha hash sha
group 2 group 2
lifetime 43200 lifetime 43200
! !
crypto ipsec ikev1 transform-set FirstSet esp-3des esp-md5-hmac crypto ipsec ikev1 transform-set FirstSet esp-3des esp-md5-hmac
! !
access-list L2L extended permit ip 10.0.1.0 255.255.255.0 10.0.2.0 255.255.255.0 access-list L2L extended permit ip 10.0.2.0 255.255.255.0 10.0.1.0 255.255.255.0
! !
tunnel-group 172.16.2.2 type ipsec-l2l Tunnel-group 172.16.1.2 type ipsec-l2l
tunnel-group 172.16.2.2 ipsec-attributes Tunnel-group 172.16.1.2 ipsec-attributes
ikev1 pre-shared-key cisco01 ikev1 pre-shared-key cisco01
! !
crypto map IPSECMAP 1 match address L2L crypto map IPSECMAP 1 match address L2L
crypto map IPSECMAP 1 set connection-type bi-directional crypto map IPSECMAP 1 set connection-type bi-directional
crypto map IPSECMAP 1 set peer 172.16.2.2 crypto map IPSECMAP 1 set peer 172.16.1.2
crypto map IPSECMAP 1 set ikev1 phase1-mode main crypto map IPSECMAP 1 set ikev1 phase1-mode main
crypto map IPSECMAP 1 set ikev1 transform-set FirstSet crypto map IPSECMAP 1 set ikev1 transform-set FirstSet
crypto map IPSECMAP interface outside crypto map IPSECMAP interface outside
interface interface
ASA0# sh ip ASA1# sh ip
System IP Addresses: System IP Addresses:
Interface Name IP address Subnet mask Method Interface Name IP address Subnet mask Method
GigabitEthernet0/1 inside 10.0.1.1 255.255.255.0 manual GigabitEthernet0/1 inside 10.0.2.1 255.255.255.0 manual
GigabitEthernet0/2 outside 172.16.0.2 255.255.255.252 manual GigabitEthernet0/2 outside 172.16.2.2 255.255.255.252 manual
Current IP Addresses: Current IP Addresses:
Interface Name IP address Subnet mask Method Interface Name IP address Subnet mask Method
GigabitEthernet0/1 inside 10.0.1.1 255.255.255.0 manual GigabitEthernet0/1 inside 10.0.2.1 255.255.255.0 manual
GigabitEthernet0/2 outside 172.16.0.2 255.255.255.252 manual GigabitEthernet0/2 outside 172.16.2.2 255.255.255.252 manual

Verification:

ping from PC1 to PC1 whicah diffrent subnet

PC1> ping 10.0.2.10

84 bytes from 10.0.2.10 icmp_seq=1 ttl=64 time=8.256 ms
84 bytes from 10.0.2.10 icmp_seq=2 ttl=64 time=11.365 ms
84 bytes from 10.0.2.10 icmp_seq=3 ttl=64 time=7.692 ms
84 bytes from 10.0.2.10 icmp_seq=4 ttl=64 time=10.106 ms
84 bytes from 10.0.2.10 icmp_seq=5 ttl=64 time=12.254 ms

 

ISAKMP Status :

SA0# sh crypto isakmp sa

IKEv1 SAs:

Active SA: 1
 Rekey SA: 0 (A tunnel will report 1 Active and 1 Rekey SA during rekey)
Total IKE SA: 1

1 IKE Peer: 172.16.2.2
 Type : L2L Role : responder 
 Rekey : no State : MM_ACTIVE

we can see the status currently MM_ACTIVE , mean Phase 1 negotiate successfull

now we verified IPSEC does it build the tunnel up?

ASA0# sh ipsec sa
interface: outside
 Crypto map tag: abcmap, seq num: 1, local addr: 172.16.0.2

access-list L2L extended permit ip 10.0.1.0 255.255.255.0 10.0.2.0 255.255.255.0 
 local ident (addr/mask/prot/port): (10.0.1.0/255.255.255.0/0/0)
 remote ident (addr/mask/prot/port): (10.0.2.0/255.255.255.0/0/0)
 current_peer: 172.16.2.2



#pkts encaps: 14, #pkts encrypt: 14, #pkts digest: 14
 #pkts decaps: 14, #pkts decrypt: 14, #pkts verify: 14
 #pkts compressed: 0, #pkts decompressed: 0
 #pkts not compressed: 14, #pkts comp failed: 0, #pkts decomp failed: 0
 #pre-frag successes: 0, #pre-frag failures: 0, #fragments created: 0
 #PMTUs sent: 0, #PMTUs rcvd: 0, #decapsulated frgs needing reassembly: 0
 #TFC rcvd: 0, #TFC sent: 0
 #Valid ICMP Errors rcvd: 0, #Invalid ICMP Errors rcvd: 0
 #send errors: 0, #recv errors: 0

local crypto endpt.: 172.16.0.2/0, remote crypto endpt.: 172.16.2.2/0
 path mtu 1500, ipsec overhead 58(36), media mtu 1500
 PMTU time remaining (sec): 0, DF policy: copy-df
 ICMP error validation: disabled, TFC packets: disabled
 current outbound spi: 1FFEC8F1
 current inbound spi : E2BB0BFB

inbound esp sas:
 spi: 0xE2BB0BFB (3803909115)
 transform: esp-3des esp-md5-hmac no compression 
 in use settings ={L2L, Tunnel, IKEv1, }
 slot: 0, conn_id: 8192, crypto-map: abcmap
 sa timing: remaining key lifetime (kB/sec): (3914998/27797)
 IV size: 8 bytes
 replay detection support: Y
 Anti replay bitmap: 
 0x00000000 0x00007FFF
 outbound esp sas:
 spi: 0x1FFEC8F1 (536791281)
 transform: esp-3des esp-md5-hmac no compression 
 in use settings ={L2L, Tunnel, IKEv1, }
 slot: 0, conn_id: 8192, crypto-map: abcmap
 sa timing: remaining key lifetime (kB/sec): (3914998/27797)
 IV size: 8 bytes
 replay detection support: Y
 Anti replay bitmap: 
 0x00000000 0x00000001

Yes it does,  since we see the show command below :

local crypto endpt.: 172.16.0.2/0, remote crypto endpt.: 172.16.2.2/0
 path mtu 1500, ipsec overhead 58(36), media mtu 1500
 PMTU time remaining (sec): 0, DF policy: copy-df
 ICMP error validation: disabled, TFC packets: disabled
 current outbound spi: 1FFEC8F1
 current inbound spi : E2BB0BFB

mean the both WAN already hanshaking and tunneled m SPI ( Security Parameter Index) is unique id does it build to identify both firewall to communicate and identify its traffict as incomming and outgoing. next we would see ehat setting are use to encrypt and Access-list use to map the traffict and IKE version been used.

spi: 0xE2BB0BFB (3803909115)
 transform: esp-3des esp-md5-hmac no compression 
 in use settings ={L2L, Tunnel, IKEv1, }

 

 

VXLAN Learn Notes: VPC Encapsulation accross peer-link

I hit got problem at labs yesterday due VPC implementation for VXLAN anycast gateway dont want to get failover.

solved by this workarround :

“vpc nve peer-link-vlan xx”

 

this is from Cisco sites :

vPC Considerations

    A virtual IP must be configured for the vPC pair
    A virtual IP must be configured for loopback purposes.
    A peer-link switched virtual interfaces (SVI) must be only on a peer-link in external communication. A configuration example:
    vpc nve peer-link-vlan 99
    interface vlan99
    no shutdown
    no ip redirects
    ip address 99.1.1.1/24
    ip ospf cost 10
    ip router ospf 1 area 0.0.0.0
    ip pim sparse-mode
    A special peer-link SVI must be configured on the VPC pair.
    VPC peers must have identical configurations:
        Consistent VLAN to VN-segment mapping.
        Consistent NVE1 binding to the same loopback interface.
            Using the same secondary IP address.
            Using different primary IP addresses.

Reff: http://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus5600/sw/layer2/7x/b_5600_Layer2_Config_7x/b_5600_Layer2_Config_7x_chapter_010010.html